I can't move my ships!!

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • I can't move my ships!!

    drive.google.com/file/d/1Vw7xJ…JyzqZ8pF/view?usp=sharing

    This is a screenshot of my game.

    Bugs I've found:
    - You can also see in the right corner of the Unit tab in the screenshot that the ships has 0.0 damage all together.
    - On this map I am playing with a friend. I tried trading the battle group with him to see if it would refresh or something but nothing happened. The trade didn't appear in our chat menu. It's as if the trade was made and then instantly automatically deleted.
    - I also can't exit the Unit tab. To get rid of it I must select another TROOP and then the water for the tab to completely disappear.
    - I can't move my ships or attack with them. They just stay frozen in the place they were made.
    - You can see that on the screenshot that when I press the split button on the unit tab it doesn't load properly.

    This is only a problem with the submarine and the battleship in the image. All my other units in this game are working perfectly fine. It is not a problem with my chromebook I have tried to move the battle group with my phone and a VERY fast computer I have at home.

    The game ID for the game this glitch is occuring is: 2244307