I can't use these units

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • I can't use these units

      First there is this other bug that has been going on for weeks that does not register PvP kills on the stats and the achievements, again? What's the point of playing if your battles don't even matter to your profile? "Whatever I'll just finish this match and then see what to do". I've been planning this invasion for over a week now, and the day I finally decide to launch it the game starts to break even more. Basically every time I click on this 3 unit army of 2 medium tanks and one anti-air escorted by a submarine that I can't get it to move, attack, or even divide, it either says error or just shows an empty window. I even tried logging on the phone and is the same thing. I know it's only 3 units but they were supposed to capture a specific province and now I have to rethink my plan at the last minute. Also, what tells me that this isn't going to happen again to an even bigger unit? All these bugs are seriously making consider not playing COW again after this match.
      Images
      • bro.PNG

        403.65 kB, 613×454, viewed 19 times
      • bro2.PNG

        643.84 kB, 801×514, viewed 16 times
    • A little bit more info, as you can see in the second photo I posted, the strenght of the unit is 0.0. I have also tried selecing all of my armies at once, looking at the summary of all my units I have 12 medium tanks, 37 subs and 22 anti air in total, counting the 4 units that are bugged, but when I press divide it only says I have 10 medium tanks, 36 subs and 21 anti air.
    • Is this a regular game or a Beta game? Either way fill in a bug report and a GO will help you as soon as possible.

      A small advice: play for fun, not for stats. This way you will enjoy more an stats don't define a good player as everyone can get nuked, backstabbed or being under attack by one or even more coalitions.
      BMfox
      Moderator
      EN Support Team | Bytro Labs Gmbh
    • Ok, firstly the stat issue is a known bug and is being worked on.

      The second issue we need to have a bug report sent in order to try a couple of things to figure it out.

      Also is this a live game or a beta game if it is beta the bug report might only go to the beta where the devs will look at it and they don't respond to tickets.
      PrinceofHonor
      Senior Game Operator
      EN Support Team | Bytro Labs Gmbh

      Click here to submit a bug report or support ticket
    • It is not a beta game, I can even give you the ID 2745347. When I got tired of waiting I fixed it by clicking on the unit like 50 times, most of the times I couldn't select any of them, a few times I could select only one of them and, as I said, I had to click like 50 times until I could finally select all of them, separate the ground units from the submarine and send them to attack. Next time I will probably break my mouse lol. Now only problem left is the stats not working, I launched the attack anyways, just killed 4 rockets from an active player for example and none gave me EXP. I know playing for the stats it's not healthy but I am a Steam Achievement hunter, getting achievements is really important for me.